Uploaded image for project: 'openATTIC'
  1. openATTIC
  2. OP-571

Error during RPM upgrade: "semanage: command not found"

    XMLWordPrintable

    Details

      Description

      After running "yum update" on my CentOS 7 system, I noticed the following error message in the installation log output:

        Updating    : openattic-gui-2.0.2-1~201508092001.el7.x86_64            32/90
      /var/tmp/rpm-tmp.WhZ2Um: line 1: semanage: command not found
      

      This error seems to be caused by the %post and %pustun install scriptlets of the openattic-gui subpackage, which both call semanage, without making sure it's actually installed. In EL7, this tool is included in package policycoreutils-python.

      The openattic-gui package either needs to have a dependency to this package, or the scriptlets need to be rewritten to achieve the desired outcome using the SELinux management tools that are installed by default.

        Attachments

          Activity

            People

            Assignee:
            lgrimmer Grimmer, Lenz
            Reporter:
            lgrimmer Grimmer, Lenz
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: