Uploaded image for project: 'openATTIC'
  1. openATTIC
  2. OP-2618

Upgrade Protractor

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.4.4
    • Fix Version/s: 3.5.0
    • Component/s: QA/Testing, WebUI
    • Labels:

      Description

      ATM we are using a old version of Protractor and Webdriver.

      We should upgrade it to the latest version (hopefully it will reduce the instability we currently have).

       

      This will also allow us to use a more recent version os nodejs, which will be needed when we start doing more tests for Angular 2+.

       

      I'm also thinking of putting protractor as a npm dependency. 

      This will remove some extra work when starting to work on the project and allow for us to have a better management of the version that is being used.

       

      The new versions are:

      • protractor: 5.1.2
      • webdriver-manager: ^12.0.6 (it's a protractor dependency)
      • jasmine: ^2.5.3 (it's a protractor dependency)
      • nodejs: 6.11.2
      • chrome: 60

        Attachments

          Activity

            People

            Assignee:
            tspmelo Tiago Melo
            Reporter:
            tspmelo Tiago Melo
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: