Uploaded image for project: 'openATTIC'
  1. openATTIC
  2. OP-1580

Ceph MON nodes aren't resolved during oaconfig install

    XMLWordPrintable

    Details

      Description

      http://bugzilla.suse.com/show_bug.cgi?id=1001370

      Nodes weren't resolved during oaconfig install. However openATTIC installation
      has completed as successful. BTW hostname resolution works fine, nodes entries
      are also in hosts file.

      $ sudo oaconfig install
      
      Checking Ceph mon ix64ph1079... Host unknown, ignored
      Checking Ceph mon ix64ph1080... Host unknown, ignored
      Checking Ceph mon ix64ph1081... Host unknown, ignored
      

      BUT:

      $ nslookup ix64ph1079
      Server:        10.162.0.1
      Address:    10.162.0.1#53
      
      Name:    ix64ph1079.qa.suse.de
      Address: 10.162.2.79
      
      $ nslookup ix64ph1080
      Server:        10.162.0.1
      Address:    10.162.0.1#53
      
      Name:    ix64ph1080.qa.suse.de
      Address: 10.162.2.80
      
      $ nslookup ix64ph1081
      Server:        10.162.0.1
      Address:    10.162.0.1#53
      
      Name:    ix64ph1081.qa.suse.de
      Address: 10.162.2.81
      
      $ ceph mon stat
      e1: 3 mons at
      {ix64ph1079=10.162.2.79:6789/0,ix64ph1080=10.162.2.80:6789/0,ix64ph1081=10.162.2.81:6789/0},
      election epoch 4, quorum 0,1,2 ix64ph1079,ix64ph1080,ix64ph1081
      

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              lgrimmer Grimmer, Lenz
              Reporter:
              ganglia Craig Gardner
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: